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Thank you for choosing this (Burning) EA (Expert Advisor). 

If you have any questions, suggestions or comments, you can easily contact us via MQL5.You can also 
find all our products here (more to come): 

https://www.mql5.com/en/users/MagmaSoftwareSolutions/seller 

 



This manual will guide you through all processes such as installation, configuration, and usage of the 
EA so that you can unlock its full potential. Please study this manual carefully in order to achieve a 
successful and smooth start with this product. 

 
Should you still have questions or need help, simply join our MQL5 chat: 

https://www.mql5.com/en/messages/0151274c579fdb01 

 

Getting Started 
Congratulations on your decision to explore the world of Expert Advisors and indicators on the MQL5 
marketplace! In this chapter, we will guide you through the most important steps to get started with 
these powerful tools and enhance your trading experience. 

 

Accessing and Purchasing 
The MQL5 marketplace is a real treasure trove of trading tools and offers a wide range of Expert 
Advisors and indicators developed by experienced traders and programmers. Here you can find a list 
of all our products on the MQL5 market: 

https://www.mql5.com/en/users/MagmaSoftwareSolutions/seller 

 

 

Buying Process 
Click the Buy button to proceed with your purchase. 



 

 

Select your payment method and then click the green Next button to proceed with your payment. 

 

 

 

Downloading, Installing and Activating Burning Grid 
After your purchase is completed, you need to open your MT5 terminal to download and install the 
Burning Grid EA. 



When you open the MT5 client, please make sure you are logged in with your MQL5 account. Use 
your MQL5 login (not your email) for this. 

 
Open the MT5 terminal and go to “Tools -> Options -> Community” and make sure you are logged in 
there with your MQL5 account. 

 

Then go to “View -> Navigator” and click on the Market folder and then on “My Purchases”. 

 

 

 

 

 



The Purchases window with all your purchases will open on the right. Now click on the Install button 
for Burning Grid. 

 

Testing Burning Grid EA with Strategy Tester 
Please test your new Expert Advisor very thoroughly. Especially some settings depend on your broker 
(e.g., spread) and must be determined by you using the Strategy Tester! 

To use the Strategy Tester, click on “View -> Strategy Tester”. 

Now click on “Expert” and select Burning Grid here. You will find it under Market. 

 

 

 

 

 

To test Burning Grid effectively, you should select a timeframe starting from 01.01.2020. Since most 
brokers do not offer test data for such a long period, we recommend selecting “1 Minute OHLC” for 
modeling. Also set the leverage offered by your broker. We recommend ICTrading, which in our 
opinion offers the best conditions on the market. 



 

Then you can choose “Inputs” to configure Burning Grid for the first test. 

 

For the first test, we recommend setting the Risk % to 1, disabling graphics for a faster test, and 
initially using only the “Lowest Risk” setting. 

A more detailed explanation of what each setting does follows below. 

Then click on “Start” to begin the test. 

 

Since more than 30 currency pairs are processed in parallel during the test, it may unfortunately take 
several hours depending on the CPU. If graphics are enabled, the time required will increase again. 
Therefore, we recommend starting the test in the evening to check the result in the morning. 

 

 

 

 



 

 

For various brokers (e.g., prop firms or trading capital accelerators such as  iFunds), it may be 
necessary to perform a complete test. 

To do this, in the Inputs under the “Optimization” section, select the options “Slow complete 
algorithm” and “Drawdown min”. 

 

In the Inputs of Burning Grid, now select the entries shown in the graphic to find the settings that 
comply with the rules of your capital accelerator. 

 

In the example, over 80,000 tests are needed: 

 

So be aware that this optimization will take a long time. But this ensures that the settings of Burning 
Grid can pass your challenges! 



For regular brokers with low spreads, such as ICTrading, this test is generally not necessary, but it 

doesn’t hurt  সহ঺঻ 

 

 

 

Now select from the list of results the one that does not exceed the maximum allowed DD of your 
capital provider (and ideally leaves some buffer). 

Setting up Burning Grid on a Demo or Live Account 
After testing Burning Grid and finding the perfect settings for your broker or capital provider, we can 
burn down the market. 

You can use the following steps for both demo and live account setups. 

1. Select a symbol chart (preferably one you also want to use) 
2. Drag and drop the Burning Grid EA onto the chart 

 

3. Enable “Allow Algo Trading” and click OK 



 

  

4. Click on Inputs. Here you can adopt the parameters from the tests (or use the default settings 
for a good broker) 



 

 

After one last click on “Ok”, Burning Grid will start and display the following dashboard: 

 

 



At the top, the profits and losses achieved so far per pair are displayed. These are roughly totaled 
and shown for the last 24 hours, the current month, the previous month, and overall. Only 
symbols with positions closed by Burning Grid are listed here. 

 

In the second section, the current spreads of the symbols are listed. This helps define the range 
for the spread in a backtest. 

 

The third section shows the current drawdowns per currency, aggregated across all open 
positions. 

 

The last section shows the current open positions (Burning Grids). These are grouped by strategy 
and symbol. 

 

Risk Management 
Burning Grid has a built-in risk management system based on the following factors: 

- Multi Chart Risk Setting: 
Here you can choose between the modes “Lowest”, “Medium”, and “High” risk. The higher 
the risk setting, the more possible strategies are considered and the more positions can be 
opened in parallel! 

 

- Risk in % für Buy und Sell Positions: 
Here you can directly enter the percentage to be risked per Buy or Sell trade. You should 
choose a value that ensures the account will survive according to the backtests! 
Please note: the Risk % for Buy and Sell Positions applies per strategy. So if a higher risk is 
chosen, more strategies will open more positions in parallel. This can, especially with the 
many pairs being traded, lead to a large drawdown up to total loss! So please choose a more 
conservative option at the beginning (e.g., 1% for Buy and Sell and Medium or Low Risk) 

 

- Max. allowed overall DD in % for Account 
The percentage entered here defines the maximum allowed drawdown for the account. If 
this is exceeded, all open positions will be closed. Afterwards, the EA will continue operating 
as usual. 
 

- Max. allowed overall DD in % for XXX (Currency) Positions 
If a percentage is entered here and the DD is exceeded, all positions with the country code 
will be closed. For the DD, ALL open positions of the country are considered (e.g., AUDUSD 



and GBPUSD positions for USD). After the positions are closed, no new positions will be 
opened for that country in the next 24h (if the VPS allows saving data). 

 

 

Burning Grid Settings 

Chart Selection 
Multichart by manual selection: only pairs marked with “On” are traded 

Multichart by Marketwatch: pairs found in the Marketwatch and processable by the EA are traded 

 



Max allowed Risk in %... 
Risk setting in percent for each individual strategy. Only values from a minimum of 0.1 to a maximum 
of 10 are accepted. Any other value causes an error. 

 

Max allowed Spread in Pts 
The maximum difference between Bid and Ask at which Burning Grid opens a new position. 

 

Disable Graphic for faster backtesting 
If set to “true”, all graphics (like the dashboard) are disabled, resulting in significantly faster test 
results. 

 

Show Spreads on Dashboard 
If “true”, the middle section of the dashboard is shown. If “false”, it is not. 

 

Pause EA 
If “true”, existing open positions are processed (including rebuy), but no new strategies are triggered 
or opened. 

 

Base Magic Number 
The base magic number for Burning Grid. Important: a numerical range of ~300 is needed for the 
many strategies. So if the base magic number remains at 1977, the range up to 2277 will be used and 
should not be occupied by other Expert Advisors! 

 

Suffix of the Symbol 
Some brokers have suffixes for the pairs (e.g., “.ix”). To ensure the symbol is recognized by Burning 
Grid, the suffix must be entered here. 

 

Multi Chart Setup – Manual Selection 
Here you can manually select the pairs to be processed for manual selection. 

 



Auto Trading 
In order for Burning Grid to place positions, Algo Trading must be enabled in the terminal. 

 

 

Please make sure your computer is ON 24/7! Since slippage and network issues can affect the 
performance of Burning Grid, we recommend using a VPS (Virtual Private Server), e.g., from 
Commercial Network Services. This way, you don’t need to have your computer on and monitor it 
constantly, but can run your EAs on a remote machine stress-free. 

 

 

Updating Burning Grid 
 

To update Burning Grid, all open positions should be closed. New versions might include strategy ad-
justments that can no longer process the currently open positions. 
To ensure that Burning Grid only handles currently open positions but does not open any new grids, 
you must switch Burning Grid to pause mode: 

 

 

Afterwards, the top line will no longer be green but will be displayed in blue: 

 



 

 

From this point on, only the open grids will be processed, but no new ones will be opened! 
Alternatively, you can also close Burning Grid and manually close the open positions. 
Once all open positions have been closed, go to the "Market" menu in MetaTrader and then to "My 
Purchases": 

 

 

Then click on “Update” and follow the steps in “Setting up Burning Grid on a Demo or Live Account”: 

 

 

 

If you are using the MQL VPS, you must migrate Burning Grid to the VPS afterwards! 

 



 

Recommendations 

Broker - ICTrading – Your Gateway to Professional Forex & CFD 
Trading 
IC Trading is a trusted brokerage firm known for its robust suite of services in the Forex and CFD 
markets. Regulated by the Financial Services Commission (FSC) of Mauritius under license number 
GB21026834, the company operates with a strong commitment to security, transparency, and client 
protection. 

Exceptional Trading Conditions 

IC Trading stands out for offering highly competitive conditions tailored to both novice and 
experienced traders. With Forex CFDs starting from spreads as low as 0.0 pips, clients benefit from 
cost-efficient trading. Thanks to strategically placed servers in the NY4 data center, transactions are 
executed rapidly and without unnecessary delay—essential for capitalizing on market opportunities. 

Flexible Account Options 

To meet the varying needs of its clients, IC Trading provides three main account types: 

 Standard Account – No commission, spreads from 0.8 pips. A great fit for manual traders and 
those who value simplicity. 

 Raw Spread Account – Spreads from 0.0 pips with a $3.5 commission per trade. Tailored for 
scalpers and advanced traders. (Required for optimal performance with the Burning Grid EA) 

 Islamic Account – A swap-free solution for clients who follow faith-based principles and 
cannot receive or pay interest. 

Practice Without the Risk 

For those looking to explore the platform or fine-tune their strategies, IC Trading also offers a risk-free 
demo account. This feature enables users to gain practical experience and test various trading 
approaches using real-time data—without putting any capital on the line. 

Ready to get started? 
Click this link to open your IC Trading account. 

 



 

 

 

 

Trading Capital Accelerator - IFUNDS – Instant Capital for 
Ambitious Trader 
iFunds.io is a modern proprietary trading firm that offers traders a fast and flexible way to access 
capital. Unlike traditional funding models, iFunds.io removes the need for challenges or evaluations. 
Traders can begin trading with capital immediately—up to $500,000—allowing them to focus purely 
on performance from day one. 

What Sets iFunds.io Apart 

 Instant Access to Capital 
No delays, no hurdles. Traders can start with a funded account instantly. 

 Customizable Profit Splits 
Choose a profit-sharing model and drawdown limits that align with your trading style and risk 
preferences. 

 No Daily Drawdown Limits 
Focus on your strategy without the pressure of daily loss restrictions. Only the overall 
drawdown matters. 



 EA and Bot-Friendly 
Algorithmic traders are welcome. Expert Advisors and trading bots (like Burning Grid) are fully 
supported—as long as they follow fair trading rules. 

 Fast Payouts 
Profits can be withdrawn at any time, with fast processing to keep your earnings accessible 
when you need them. 

 Scalable Accounts 
As your performance grows, so can your funding. Profits can be reinvested to access larger 
capital tiers. 

Account Options for Every Trader 

iFunds.io offers a range of account sizes, each designed to suit different trading goals: 

 Intern – Start with $2,500 in capital and a 50% profit split. 

 Starter – Begin with $5,000 and grow with experience. 

 Ambitious – Access $10,000 in capital, ideal for more aggressive strategies. 

All accounts come with a 10% maximum loss limit, no daily drawdowns, and no time pressure or 
trading day minimums. 

Extra Perks 

 Public Leaderboard – Gain recognition by showcasing your trading results. 

 Copy Trading – Monetize your strategies by allowing others to follow your trades. 

 Global Accessibility – Trade from anywhere, with full flexibility for your trading setup. 

iFunds.io empowers traders with capital, freedom, and opportunity—without the traditional 
roadblocks. 

 

 

 



 

FTMO – The Professional Path to Proprietary Trading 

FTMO is one of the most recognized and well-established proprietary trading firms worldwide. It 
offers talented and disciplined traders the opportunity to trade with up to $200,000 in starting capital 
– and with consistent performance, even up to $400,000. What sets FTMO apart: there is no instant 
funding. Instead, the firm relies on a transparent, two-phase evaluation model that fairly assesses 
performance and risk management.  
 

What Makes FTMO Stand Out 

 No Time Pressure 
Traders can take as much time as they need to meet their trading objectives. 

 Two-Step Evaluation Process 
The path to an FTMO Account consists of two phases: the FTMO Challenge and the 
Verification. In the Challenge phase, traders aim to achieve a 10% profit target without 
exceeding defined loss limits. The Verification phase requires a 5% profit target. 

 Attractive Profit Share 
Successful traders keep 80% of their profits. Through the Scaling Plan, this can increase to 
90%. 

 Regular Payouts 
Payouts can be requested 14 days after the first trade. After that, payouts are available every 
14 days. 

 Scaling Plan for Growing Capital 
With consistent performance, the trading account is increased by 25% every four months, up 
to a maximum of $400,000. 

 



Account Types for Different Trading Styles 

 Classic Account – For day traders who open and close positions within the same day. 
Leverage up to 1:100. 

 Swing Account – For traders who hold positions overnight or over the weekend. Leverage up 
to 1:30. 

Additional Advantages 

 Diverse Trading Platforms – Support for MetaTrader 4, MetaTrader 5, cTrader, and DXtrade. 

 Wide Range of Instruments – Forex, indices, commodities, stocks, and cryptocurrencies. 

 Transparent Rules and Conditions – Clear limits: maximum daily loss of 5% and maximum 
overall loss of 10%. 

FTMO offers ambitious traders a structured platform to trade with company capital and take their 
trading career to the next level. 

 
 

VPS – Commercial Network Services 
Why Running a Forex EA on a VPS 

For traders relying on Expert Advisors (EAs) in the forex market, operating through a Virtual Private 
Server (VPS) can make a world of difference. A VPS allows your trading system to function 
independently of your personal computer—meaning trades continue to be placed around the clock, 
regardless of local power outages or internet disruptions. 

Because VPS hosting is optimized for speed, it significantly reduces latency, enabling quicker trade 
execution and minimizing slippage. Security is another major plus: by separating your trading 
environment from your personal device, you protect your strategy from viruses, malware, and system 
crashes. 



In short, a VPS offers a stable, secure, and uninterrupted trading experience that’s essential for 
serious forex traders. 

Why Many Traders Trust Commercial Network Services (CNS) 

CNS is a top-tier VPS provider recognized in the forex community for its high-performance 
infrastructure and commitment to uptime. 

 Ultra-low latency means trades are processed with near-instant speed. 

 Full compatibility with Windows (64-bit), Linux, macOS, and mobile platforms. 

 Your EA stays active 24/7, with no manual intervention needed. 

 Security features include real-time antivirus scanning, regular backups, and automatic system 
optimization. 

 Advanced protections like dual firewalls and packet monitoring keep your data safe. 

 Responsive 24/7 support is always available to assist you. 

 

 

https://trader.ftmo.com/?affiliates=hEgLCVYIshOwRknSIMOn 

 

Ready to level up your trading setup? Host your EA with CNS. 

 



 

 

 

 


